End User Manual:Using the OpenOffice.org suite

From LQWiki
Jump to: navigation, search

OpenOffice.org (OOo) is a complete office suite, featuring a word processor (Writer), a spreadsheet application (Calc), and presentation software (Impress). Besides these fundamental office applications OOo also includes a vector drawing tool (Draw), allows database access, allows the publishing of documents in the Portable Document Format (PDF) and presentations in the Flash (SWF) format!

The OOo package is partly interoperable with the Microsoft Office suite.

Getting around the package

As a first stop for information, it is important to know how the Help system works. To get help:

Help --> Contents

A search function exists. Pay attention to the Options (where you can get help for the individual components in OpenOffice.org).

Setting up OpenOffice.org preferences so that it works the way you want it to is significant. The entire controls for this are available at:

Tools --> Options

Here you can setup settings like the default measurement units, font substitution, language types and many more options. Saving a document automatically is not setup by default, so turning this feature on might be helpful: you find it at the Load/Save option, under the General sub-section.

There are three important toolbars to know:

Main toolbar – this is typically located right below the menus, and contains items like new document, save a document, exporting to PDF, copying & pasting, as well as access to the Navigator, Stylist, and Gallery.

Object toolbar – this is right below the main toolbar, and has access to font control, and other attributes of objects.

Function toolbar – located at the left-corner of the screen, and contains many options including quick table generation, insertion of objects, and many more.

Writer

The OpenOffice Writer is a word processor that allows easy integration of charts and pictures, as well as other OpenOffice.org-compatible documents. It can create everything from a simple letter to books, with professional layouts.

You are now presented with the word processing portion of OpenOffice.org, and the interface is rather similar to other word processing tools available. Rather than providing guidance throughout the entire package, we will just concentrate on a few tasks at hand.

Common Operations

For operations while writing, it is common to want to select a lot of text, copy it, maybe cut it from its current location and paste it elsewhere, or even undo an action. All this is possible with the office suite, and such options are available at the Edit menu. A few common options are:

To copy text: select the text with the mouse, then select Edit --> Copy. Now the selected text is kept in memory for use elsewhere.

To paste text: find the spot where text needs to be placed, place the cursor there, and then select Edit --> Paste.

To cut text: this means that the selected text will be removed from the current location and kept in memory, to be placed elsewhere. Doing this is exactly like how a copy should be performed, except selection Edit --> Cut instead.

To undo an action: Select Edit --> Undo. It will display the command that it is undoing at the moment.

By browsing the menu, there are also keyboard shortcuts located next to it. Once more proficient use of the package occurs, it is much quicker to use keyboard shortcuts like Control+C for Copy, and so on.

Formatting

You can format one or more characters to be bold, italic or underlined using the toolbar at the top of the screen.

Let's switch to the end of the toolbar, and notice that the options there including providing a paragraph background – which is good for highlighting a paragraph or several paragraphs of text, in colours that you choose. You can also highlight text (like you would with a highlighter and paper!), and change the font colours all with the icons there.

Those were just quick controls. To get full control, using the Format menu is ideal. Controls are more varied here.

Styles

If you write a book or a master thesis using OpenOffice you will want e.g. all your headings to look consistent. The solution to this are styles. Type F11 to pop up the Stylist. Choose a style (e.g. "Heading 1") or create your own one. By right-clicking on the style, there are options to modify the style, or create new custom ones.

By going to the modify option, the style can be customized via many varying attributes including spacing, alignment, font, emphasis, colour and many more. Once suitable styles have been pre-defined in the document, they can be used on existing text just by selection, and double-clicking on the style name.

Spell checker

Writer has a built-in spell checker. This can be accessed via:

Tools --> Spellcheck

The option to auto-spellcheck means that while typing, Writer will dynamically check your spelling, and if it detects an error, it will output a red-line at the bottom of the misspelled word. Keep in mind that the spell checking is based on the current language that is in use. This can be changed via:

Tools --> Options --> Language Settings --> Languages

Accessing word counts in the document is different to most other packages on a default install of OpenOffice.org (this can differ with several Linux distributions' offerings):

File --> Properties --> Statistics

It is under the Statistics tab that the word counts and other relevant document counts are based. On certain vendor modified distributions of OpenOffice.org, going to the Tools --> Word Count menu will allow the Statistics dialogue box to be displayed automatically.

AutoCorrect

The AutoCorrect/AutoFormat (Tools --> AutoCorrect/AutoFormat) options have replacement tables (so that CDs really are valid, and will not be changed to Cd, for instance). There are also word completion options (very useful, as the software starts thinking for you) and settings to make them more user-friendly.

Navigator

The Navigator is a yet another useful tool (get this via hitting the F5 key or clicking its icon on the main toolbar), especially when dealing with larger documents. It supports jumping to bookmarks, notes, any particular object, and even creates a table-of-contents on the fly, based on the styles that are being used!

Tracking Changes

When you are asked to change a text from another person, you want that your changes can be distinguished from the original text. To do this, choose

Edit -> Changes -> Record

And your changes will be in red.

Calc

This is the spreadsheet component of the OpenOffice.org package, and contains many useful features, including an array of functions and plenty of charting options. It is fully interoperable with Microsoft Excel, though the function separators differ in the two packages.

To start this, it is available via

Main Menu --> Office --> OpenOffice.org Calc

or if you already have an existing window of OpenOffice.org open,

File --> New --> Spreadsheet.

Spreadsheets contain many rows and columns, and each row and column combination is called a cell (like A1, B4, and so on). Upon inputting text into a cell, you might realize that the text is wider than the cell allows for – this can be re-sized via right-clicking the cell, and selecting the Format Cells option. There under the Alignment tab, selecting Line Break is what is required.

Formatting

Like other parts of OpenOffice.org, Calc also comes with the Stylist. But let's get around to understanding the various differing formatting options available in this component of the package.

If there is some information that you already have created, and the area should be formatted, one particular quick and easy option is to use the AutoFormats available in Calc. This is done after selecting the area then:

Format --> AutoFormat

These are pre-defined styles that are available in Calc, and if you have created your own particular style, you can add them into your new AutoFormats.

In the object toolbar, there is an option to set the font colour within the cell. There are also options to increase/decrease the indents within a cell, and in the image below, controls for enabling:

Currency Percentage Add/Remove significant decimal places

These are quick controls, and accessing them is as simple as clicking the icons that represent them, and automatically the cell will be formatted as stated. Not only can Borders be set easily, and cell backgrounds too, but the alignment of text within a cell can also be set. This can be either as a top aligned, centre aligned, or bottom aligned.

Now that most of the formatting options are known, it is easy to apply Styles to the spreadsheet – bring up the Stylist by hitting the F11 key, and you'll notice that cell styles (that control all elements, including formatting) and page styles can be set (the latter controlling margins, headers/footers, and borders).

Spreadsheet basics

There are a few points to note when using a spreadsheet. One of them is that calculations are performed in a left-to-right format, with algebraic ordering rules. This means it deals with brackets (“()”) first, then division (“/”), multiplication (“*”), addition (“+”) and finally subtraction (“-”).

When applying calculations, keep in mind the range of included cells. When using a function like =SUM(), and using the argument =SUM(A1:A4), it means it looks for the sum of the cells A1, A2, A3, and A4. These operations can also be performed on non-consecutive cells, so, =SUM(A1;A4;A7) just executes the sum of cells A1, A4 and A7.

If you have used Excel before, it would be relatively common to use a comma (“,”) as a separator character between the parameters, however, with OpenOffice.org Calc, the separator character is a semi-colon (“;”). So for the function to validate correctly, an expression such as =IF(B3>0;A1-A2;A1+A2) is correct (as opposed to replacing the “;” with “,”).

Building functions

To perform calculations, spreadsheet make use of functions. Common functions include =SUM() for summation, =AVERAGE() for the average value of cells, and so on. As an aid to the novice user, OpenOffice.org provides a Function AutoPilot. This is a wizard to help build formulas, and find problems with existing expressions.

Located next to the universal sum function, is the Function AutoPilot. If you click on in, a pop-up dialogue appears.

1.In the Functions tab, you can filter viewable/accessible functions via category, and the option to choose a function is shown. Use your mouse to choose a function that you plan on using.

2.Once the correct function is selected, and the action that it performs is agreeable (it is displayed on the right of the dialogue), select Next to move on.

3.Now you are allowed to input numbers. Assuming the AVERAGE function was chosen, in the number 1 field (for example), there are options to either enter a function or select a range of cells.

4.Use select a range of cells, and now a different dialogue pop's up and you can use the mouse cursor to select a range of cells. Click on OK, and you're done!

That is a very easy way to build a formula, which requires no pre-requisite knowledge about what formulas exist in Calc.

Sorting

A big part of dealing with spreadsheets involves a lot of sorting and filtering of data. To sort a dataset, selecting the active cells, then clicking

Data --> Sort

will bring a pop-up dialogue that has options for sorting the data based on the columns present, as well as if the data should be ascending or descending.

Charting

Converting data into information is a process usually accomplished well by creating graphs and charts – it is a lot easier to infer based on visual graphics, rather than lots of numbers. Calc provides a charting wizard that will allow this to be automated rather easily, with a lot of predefined settings.

  1. Select the cells that are to be charted, and then go to Insert --> Chart.
  2. The range is pre-selected, and certain options are provided (like where the resulting chart is); just leaving the pre-selected options will be good for the exercise. Click Next.
  3. A type of chart is to be chosen – common charts include pie chart, line graphs, or even bar graphs – it all depends on the information being represented.
  4. Select the defaults, and create a chart. (You should now see a bar chart created).

Now that a chart has been created, it is not static in the sense that it cannot be edited – you can control each and every aspect of how the chart looks. Double-click the chart, and you will now go into edit mode. Notice the toolbar by the left-hand side of your screen has changed? This is in direct response to it being in edit mode, and a lot of properties can be changed here.

There are plenty more features, like data filtering, scenario creation, and goal seek, which once you get more advanced with spreadsheet know-how, you will end up making use of.

Impress

No office suite is complete without a presentation piece, and OpenOffice.org shows its colours with Impress, the presentation piece of the suite. To start it, it is available at

Main Menu --> Office --> OpenOffice.org Impress

or if you already have an OpenOffice.org window open, it's available at

File --> New --> Presentation.

Unlike other components of OpenOffice.org, when you start Impress, you are presented with an AutoPilot, to start creating your presentation! This gives you options to start a presentation with an empty template, or even with one of the pre-defined templates. A preview dialogue is available, and once all options are selected (and Next is clicked, to move on), you get a basic presentation.

Template Management

If a big portion of time is going to be spent giving presentations, it's very professional to have the presentation look like each other, in the form of a template (same logo position, copyright notices, etc...). Once a template is created (or downloaded from the Internet), you manage templates via the:

File --> Template --> Organize

Slide Design

A quick way to get slides done is via turning on:

View --> Toolbars --> Presentation

This provides a pop-up menu option that allows you to insert slides, or even modify the slide layout of the current slide.

Views

There are several views in Impress, and some have over-lapping names, but with different functionality! At the top-right-hand-corner of your screen, just above the scroll bars, you'll notice five buttons that look like what you see below.

The six options for workspace views are:

  1. Drawing view – default, for slide design.
  2. Outline view – overlook of the presentation.
  3. Slide view – birds eye view to add, change, switch slides around.
  4. Notes view – add speaker notes.
  5. Handout view – how handouts get printed.
  6. Start slideshow – run the presentation.

All the views can also be accessed via:

View --> Workspace

It is also worthwhile to note that at the bottom-left-hand-corner of your screen, where the slide tabs are displayed, there are more views to know about. You are typically located in the Slide View (same name as above, but different functionality since it's on a different bar!)

However, Master Views are supported and to access this view, it is the second button from the left. You can have master views of all workspace views (that is, a master view of the slide itself, notes, and handouts). The Layer view allows layering of slides (adding and removing), and layers can be non-printing or non-displayed on screen, but printing only.

Jazzing up the presentation

Objects, like video, Java applets, music, and even other graphics can be added (embedded) to a presentation very easily. To perform this, the following menu is useful:

Insert --> Object

Keep in mind that OpenOffice.org will only play content provided all relevant plug-in's are installed. For sound playback, it assumes an already configured sound-card, otherwise it will not work.

Effects are another supported feature in Impress and consist of things like slide transitions, mouse-driven bullet-points, and even drawing animations. To get to the effects pop-up:

Slide Show --> Effects

A common effect is one where each bullet point appears upon a mouse-click. This event-driven effect is easily performed via selecting the “Appear” effect. Once that is selected, ticking the green tick (in acceptance) is necessary.

Performing slide transitions are also performed via the effects menu. However, to create animations, the menu is:

Slide Show --> Animation

Here simple animations can be created, like a bouncing ball along a line, for instance. This is done simply via:

1.Draw a circle (ball!).

2.Then draw a curve, as the path the curve should travel.

3.Select the “Move along curve” effect, and apply it (as in the figure below).

4.Now when the presentation is run, the ball will move along the line.

Conclusion

OpenOffice.org has the ability to be a very useful software package – it includes very powerful, free alternatives to satisfy average office suite requirements. As this is only scratching the surface, there are plenty more resources available out there, so please, use the available documentation to its fullest.



This article is part of the End User Manual, which is based, in whole or in part, on "User Guide to Using the Linux Desktop", by Nah Soo Hoe and Colin Charles. It was released by the copyright holders, the United Nations Development Programme’s Asia-Pacific Development Information Programme (UNDP-APDIP), under the terms of the Creative Commons (attribution variant) license. The original can be found here: http://www.iosn.net/training/end-user-manual/ .

The End User Manual is intended for the use of users without prior Linux or PC experience who wish to learn how to use linux. The original authors intended for the User Guide to be as generic as possible, but in some cases, this was not possible. In these cases, Fedora was used as a baseline. All desktop directions use refer to the Gnome desktop. These choices are not intended as an endorsement of these programs.